1. Home
  2. Linux
  3. Python Installation Error – Ignoring ensurepip failure: pip 7.1.2 requires SSL/TLS [Solved]

Python Installation Error – Ignoring ensurepip failure: pip 7.1.2 requires SSL/TLS [Solved]

I was trying to compile Python from source – the steps involved are configure, make, make install and luckily everything went on well. But at the end of make install, I get this error message “Ignoring ensurepip failure: pip 7.1.2 requires SSL/TLS“. I do have OpenSSL installed as shown below.

# rpm -qa|grep openssl
openssl-1.0.1e-30.el6_6.5.x86_64

Here’s the steps that I followed and the error message at the end.

#./configure
#make

python ssl/tls error

#make install
 :::::::::::::::::::::::
 rm -f /usr/local/share/man/man1/python3.1
 (cd /usr/local/share/man/man1; ln -s python3.5.1 python3.1)
 if test "xupgrade" != "xno" ; then \
 case upgrade in \
 upgrade) ensurepip="--upgrade" ;; \
 install|*) ensurepip="" ;; \
 esac; \
 ./python -E -m ensurepip \
 $ensurepip --root=/ ; \
 fi
 Ignoring ensurepip failure: pip 7.1.2 requires SSL/TLS

Solution:

As the error says Python Pip needs SSL package to be installed. You have to install ‘openssl-devel‘ package.

#yum install openssl-devel

That’s it!

Other Python Errors and Solutions

Updated on September 19, 2017

Was this article helpful?

Related Articles

Leave a Comment